Ticket #113 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Create a default inventory slice for broker on startup

Reported by: aydan Owned by: prateek
Priority: major Milestone:
Component: ORCA: Shirako Core Version: Bella 2.1
Keywords: Cc:

Description


Change History

Changed 9 years ago by prateek

  • status changed from new to accepted
  • owner changed from aydan to prateek

Changed 9 years ago by prateek

We already have code for that in place. The issue is that the default slices at broker and SM are as of now being created as client slices.

There is no notion of a client slice at SM and also the client slice that is being created as the broker cannot be used for any reservation as the same does not have a presence at the SM.

This should be changed and the default slices should be created as inventory slices.

Changed 9 years ago by prateek

  • status changed from accepted to closed
  • resolution set to fixed

Changed code to create default slices at SM and broker as inventory slices instead of client slices.

Modified files:
/boot/src/main/java/orca/boot/ConfigurationProcessor.java : Revision 2430

Note: See TracTickets for help on using tickets.