Ticket #208 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

GUI hangs on the Broker side when trying to claim with a valid id from an unreachable site

Reported by: anirban Owned by: ibaldin
Priority: major Milestone:
Component: Don't Know Version:
Keywords: Cc:

Description

Bring up broker and site, copy the reservation id of exported resources on the site, take down the site and then claim on the broker side with that reservation id. The GUI hangs in this scenario.

Change History

Changed 8 years ago by anirban

  • status changed from new to closed
  • resolution set to fixed

The problem is fixed. If the claim fails on a site that is down, the broker waits for the timeout period (2 minutes) and then returns with the correct error notice that the claim has failed.

Note: See TracTickets for help on using tickets.