Ticket #221 (closed defect: fixed)

Opened 8 years ago

Last modified 7 years ago

Filter out unit.ndl.adomain from being returned to the user

Reported by: ibaldin Owned by: ibaldin
Priority: minor Milestone: Dungeness 4.0
Component: ORCA: Shirako Core Version: Camano 3.1
Keywords: Cc:

Description

It's a pool resource.ndl.adomain that becomes a unit property. Need to add filtering to avoid it being returned.

Change History

Changed 8 years ago by ibaldin

From Aydan:

Look at UnitSet?.encode. It calls Unit.save for every unit in the
UnitSet?. You would want to create a new method in Unit:
Unit.saveForReturnToClient().
This one should be similar to save(), but it should not serialize the
properties you do not want. In UnitSet?.ecode replace the call to
Unit.save() with Unit.saveForReturnToClient().

I am not sure what is the best way to handle the exclusion list. It is
specific to a policy/control, but it is done by the core. For now you
can hardcode the properties you do not want. I can think more about a
better way to do this architecturally.

Changed 8 years ago by ibaldin

This is the best I could find.. grep-ing is returning the entire ndl, and hence difficult to parse.. The logs (orca.log*) to look at are in /tmp on geni.renci.org

<property name\\\\\\\\\\\\\\="resource.domain.type" value\\\\\\\\\\\\\\="3"/>\\\\\\\\n <property name\\\\\\\\\\\\\\="resource.ndl.adomain.type" value\\\\\\\\\\\\\\="4"/>\\\\\\\\n <property name\\\\\\\\\\\\\\="resource.ndl.adomain.label" value\\\\\\\\\\\\\\="Abstract Domain NDL"/>\\\\\\\\n <property name\\\\\\\\\\\\\\="resource.domain.label" value\\\\\\\\\\\\\\="NdlResourcePoolFactory?\\\\\\\\\\\\\\: Name of the domain of this resource"/>\\\\\\\\n <property name\\\\\\\\\\\\\\="resource.ndl.adomain.value"\\\\\\\\\\\\\\="Abstract Domain NDL"/.….

resource.ndl.adomain.type
resource.ndl.adomain.label
resource.ndl.adomain.value

Changed 8 years ago by ibaldin

  • status changed from new to accepted

Changed 7 years ago by ibaldin

  • milestone changed from Camano 3.1 to Dungeness 4.0

Changed 7 years ago by ibaldin

  • status changed from accepted to closed
  • resolution set to fixed

It is needed, however now it is compressed, so the issue is resolved.

Note: See TracTickets for help on using tickets.