Ticket #237 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Resources are exported from a site only for about 17 days on a deployment

Reported by: anirban Owned by: aydan
Priority: major Milestone: Dungeness 4.0
Component: Don't Know Version: baseline
Keywords: Cc: ibaldin@…

Description

There seems to be a limit on the length of time that resources are delegated from a site to a broker. i.e. when you click Site - > view exported resources , the time at which the delegation expires is about 17 days from the start time. Can we configure this somehow ? Or, is it possible to change this default somewhere in the code ?

Change History

Changed 7 years ago by anirban

  • status changed from new to closed
  • resolution set to worksforme

. If I put <start>/<end> tags in both <pool> and <rset> sections, it works fine. So, the problem is solved for the time being.

2. If I don't put the start/end tags in pool/rset sections, it fails to instantiate actors, as below.

2012-01-12 10:59:38,732 [Thread-8] INFO orca - Creating an actor: name=renci-vm-site
2012-01-12 10:59:38,844 [Thread-8] ERROR orca - Failed to instantiate actors
orca.shirako.container.ConfigurationException?: Unexpected error while creating actors

at orca.boot.ConfigurationProcessor?.createActors(ConfigurationProcessor?.java:180)
at orca.boot.ConfigurationProcessor?.process(ConfigurationProcessor?.java:133)
at orca.boot.ConfigurationLoader?.process(ConfigurationLoader?.java:82)
at orca.shirako.container.OrcaContainer?.loadConfiguration(OrcaContainer?.java:746)
at orca.shirako.container.OrcaContainer?.loadConfiguration(OrcaContainer?.java:706)
at orca.shirako.container.OrcaContainer?.initialize(OrcaContainer?.java:218)
at orca.shirako.container.Globals.start(Globals.java:98)
at orca.shirako.container.Globals.start(Globals.java:71)
at orca.shirako.container.ContainerServletContextListener?.contextInitialized(ContainerServletContextListener?.java:20)
at org.apache.catalina.core.StandardContext?.listenerStart(StandardContext?.java:4723)
at org.apache.catalina.core.StandardContext?$1.call(StandardContext?.java:5226)
at org.apache.catalina.core.StandardContext?$1.call(StandardContext?.java:5221)
at java.util.concurrent.FutureTask?$Sync.innerRun(FutureTask?.java:303)
at java.util.concurrent.FutureTask?.run(FutureTask?.java:138)
at java.util.concurrent.ThreadPoolExecutor?$Worker.runTask(ThreadPoolExecutor?.java:886)
at java.util.concurrent.ThreadPoolExecutor?$Worker.run(ThreadPoolExecutor?.java:908)
at java.lang.Thread.run(Thread.java:662)

Caused by: java.lang.NullPointerException?

at orca.boot.ConfigurationProcessor?.readResourcePools(ConfigurationProcessor?.java:573)
at orca.boot.ConfigurationProcessor?.doSpecific(ConfigurationProcessor?.java:549)
at orca.boot.ConfigurationProcessor?.createActor(ConfigurationProcessor?.java:327)
at orca.boot.ConfigurationProcessor?.createActors(ConfigurationProcessor?.java:174)

3. If I put start/end tags in the rset section and not in the pool section, it throws the same exception, as above.

4. If I put start/end tags in the pool section, but doesn't put them in the rset section, it defaults to 17 days.

Changed 7 years ago by ibaldin

  • status changed from closed to reopened
  • resolution worksforme deleted
  • milestone changed from Camano 3.1 to Dungeness 4.0

We should change the default to something more sane and document this better.

Changed 7 years ago by ibaldin

  • status changed from reopened to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.