Ticket #293 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

NDL Conversion issues early 2014

Reported by: ibaldin Owned by: ibaldin
Priority: major Milestone:
Component: External: NDL Converter Version: baseline
Keywords: Cc: yxin@…

Description

This ticket enumerates NDL conversion issues requiring attention.

Attachments

IG-ST-4.rspec (1.3 kB) - added by ibaldin 5 years ago.
Bare-metal-to-bare-metal stitch request
bbn-ad-01-30.rdf (58.4 kB) - added by ibaldin 5 years ago.
BBN NDL Ad
stitchexocheck-createsliver-request-11-exogeni-net-bbnvmsite.xml (29.3 kB) - added by ibaldin 5 years ago.
Divya's 5-node stitch RSpec with stitching extension
ln2bare-createsliver-request-11-exogeni-net-bbnvmsite.xml (5.8 kB) - added by ibaldin 5 years ago.
Bare-metal stitch request with stitching extension

Change History

  Changed 5 years ago by ibaldin

Problem 1:

From Sarah Edwards

I requested two nodes connected by a link from ExoSM using the attached request RSpec with omni and my Portal credentials. One node was bound to GPO EG and the other to RENCI EG. This reservation worked like a charm, but I saw some small issues with the manifest which I thought you'd like to know about.

My request describes the link as follows:

<link client_id="stitched0">

<component_manager name="urn:publicid:IDN+exogeni.net:bbnvmsite+authority+am"/>
<component_manager name="urn:publicid:IDN+exogeni.net:rcivmsite+authority+am"/>
<interface_ref client_id="VM-0:if0"/>
<interface_ref client_id="VM:if0"/>
<property source_id="VM-0:if0" dest_id="VM:if0" capacity="100000"/>
<property source_id="VM:if0" dest_id="VM-0:if0" capacity="100000"/>

</link>

The manifest describes the link as:

<link client_id="stitched0" sliver_id="urn:publicid:IDN+exogeni.net+sliver+d77ac112-8005-4db1-92b6-dd14615282e8:stitched0" vlantag="unknown">

<interface_ref client_id="VM:if0"/>
<interface_ref client_id="VM:if0"/>

</link>

I see three issues with the manifest:

  • The two component_manager tags were dropped
  • The two property tags were dropped
  • The client_id for both interface_ref tags is the same which doesn't make sense.

  Changed 5 years ago by yxin

Problem 2: stitching port to baremetal request rspec:

Problem 3: The vlan ranges in Ad are not per (border) interface.

  Changed 5 years ago by ibaldin

Problem 4: Possibly an issue with converter for stitchports (GENI stitching).

  Changed 5 years ago by ibaldin

Regarding Problem 3 (from Tim):

There are some issues in the stitching piece of the advertisement. I
see both stitchports advertised, but they list an overlapping set of
VLANs. In particular, I currently see the following set of VLANs
advertised on the stitching port facing I2 and the stitching port facing
the GPO InstaGENI rack:

3736-3739,2601-2610,2400-2500,3741

I am expecting to see the following for the port facing Internet2:
urn:publicid:IDN+exogeni.net:bbnNet+interface+BbnNet:IBM:G8052:GigabitEthernet:1:2:ethernet
VLANs: 3736-3739,3741

I am expecting to see the following for the port facing gpo-ig:
urn:publicid:IDN+exogeni.net:bbnNet+interface+BbnNet:IBM:G8052:GigabitEthernet:1:1:ethernet
VLANs: 2400-2500

You'll notice that 2601-2610 were omitted from what I am expecting to
see... those particular VLANs are reserved for ExoGENI, but they go to
NLR, which is not currently configured for GENI stitching.

Changed 5 years ago by ibaldin

Bare-metal-to-bare-metal stitch request

  Changed 5 years ago by ibaldin

Problem 1 (except for component managers, because it isn't clear which component managers to put there - some are not known in GENI) addressed in r6098.

  Changed 5 years ago by ibaldin

The attached RSpec IG-ST-4.rspec does not contain the stitching extension.

  Changed 5 years ago by ibaldin

Regarding Problem 3:

The NDL abstract ad contains the following:

<rdf:Description rdf:about="http://geni-orca.renci.org/owl/bbnNet.rdf#BbnNet/IBM/G8052/availableVLANSet">

<j.1:hasBroker rdf:resource="https://geni-orca.renci.org/owl/orca.rdf#ExoGENIBroker"/>
<j.2:element rdf:resource="http://geni-orca.renci.org/owl/bbnNet.rdf#BbnNet/IBM/G8052/NLRVLANSet/1"/>
<rdf:type rdf:resource="http://geni-orca.renci.org/owl/collections.owl#Set"/>
<j.2:size rdf:datatype="http://www.w3.org/2001/XMLSchema#int">5</j.2:size>
<j.2:element rdf:resource="http://geni-orca.renci.org/owl/bbnNet.rdf#BbnNet/IBM/G8052/IONVlanSet/1"/>
<j.1:hasServiceElement rdf:resource="https://geni-orca.renci.org/owl/orca.rdf#ExoGENIBroker"/>
<rdf:type rdf:resource="http://www.w3.org/2000/01/rdf-schema#Resource"/>
<rdf:type rdf:resource="http://geni-orca.renci.org/owl/layer.owl#LabelSet"/>
<rdf:type rdf:resource="http://www.w3.org/2002/07/owl#NamedIndividual"/>
<j.2:element rdf:resource="http://geni-orca.renci.org/owl/bbnNet.rdf#BbnNet/IBM/G8052/InstaGeniVlanSet/1"/>
<j.2:element rdf:resource="http://geni-orca.renci.org/owl/bbnNet.rdf#BbnNet/IBM/G8052/VLANLabel/3741"/>
<j.1:hasServiceElement rdf:resource="http://geni-orca.renci.org/owl/domain.owl#VLAN"/>
<rdf:type rdf:resource="http://www.w3.org/2002/07/owl#Thing"/>
<j.1:hasResourceType rdf:resource="http://geni-orca.renci.org/owl/domain.owl#VLAN"/>
<rdf:type rdf:resource="http://geni-orca.renci.org/owl/collections.owl#Collection"/>

</rdf:Description>

Which combines all available label sets (NLR, ION, InstaGENI) on the same interface. So the converter can't tell where those sets go and combines them together.

Changed 5 years ago by ibaldin

BBN NDL Ad

  Changed 5 years ago by ibaldin

Problem 4: the current model doesn't allow for stitching to the same physical port with multiple labels. The issue is that the physical port URL is used in reference to the "virtual" stitching port, so multiple labels end up multiplexed onto the same URL and are no longer distinguishable. Here is a request Fluke produces (which is consistent with NDL converter output as well):

<rdf:Description rdf:about="http://url1.com">

<ip4:localIPAddress rdf:resource="http://geni-orca.renci.org/owl/2e7f6c36-0f57-445e-8bdb-d060da640ae9#Link0-StitchPort0-ip-172-16-0-6"/>
<layer:label rdf:resource="http://geni-orca.renci.org/owl/2e7f6c36-0f57-445e-8bdb-d060da640ae9#Label-10"/>
<ip4:localIPAddress rdf:resource="http://geni-orca.renci.org/owl/2e7f6c36-0f57-445e-8bdb-d060da640ae9#Link1-StitchPort1-ip-172-16-0-2"/>
<layer:label rdf:resource="http://geni-orca.renci.org/owl/2e7f6c36-0f57-445e-8bdb-d060da640ae9#Label-20"/>
<rdf:type rdf:resource="http://geni-orca.renci.org/owl/topology.owl#Interface"/>

</rdf:Description>
<rdf:Description rdf:about="http://geni-orca.renci.org/owl/2e7f6c36-0f57-445e-8bdb-d060da640ae9#StitchPort1">

<topology:hasInterface rdf:resource="http://url1.com"/>
<request-schema:inDomain rdf:resource="http://geni-orca.renci.org/owl/orca.rdf#Stitching/Domain"/>
<rdf:type rdf:resource="http://geni-orca.renci.org/owl/topology.owl#Device"/>

</rdf:Description>

Changed 5 years ago by ibaldin

Divya's 5-node stitch RSpec with stitching extension

Changed 5 years ago by ibaldin

Bare-metal stitch request with stitching extension

follow-up: ↓ 10   Changed 5 years ago by ibaldin

Per conversation with Yufeng regarding Problem 3 - converter may not be looking at the right port in the advertisement. Ports facing the rack have all labels defined on a single port. Ports facing outside have labels defined per proper port.

in reply to: ↑ 9   Changed 5 years ago by ibaldin

Replying to ibaldin:

Per conversation with Yufeng regarding Problem 3 - converter may not be looking at the right port in the advertisement. Ports facing the rack have all labels defined on a single port. Ports facing outside have labels defined per virtual port.

  Changed 5 years ago by ibaldin

  • status changed from new to closed
  • resolution set to fixed

Closing summary:

Problem 1: resolved in r6098 (see ablove)

Problem 2: Invalid issue, ticket #298

Problem 3: resolved in r6116 r6117

Problem 4: Moved to separate ticket #299

Note: See TracTickets for help on using tickets.