Ticket #297 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Manifest visualization issues for multipoint and stitchports

Reported by: yxin Owned by: ibaldin
Priority: major Milestone:
Component: External: FLUKES Version: baseline
Keywords: Cc: ibaldin

Description

For meshed inter-domain topology, the manifest shows extra meshed links between the rack net nodes and the ion/NLR nodes.

Attachments

complex.rdf (25.5 kB) - added by yxin 5 years ago.
complex-manifest.rdf (251.5 kB) - added by yxin 5 years ago.
broken-paths.rdf (219.4 kB) - added by ibaldin 5 years ago.
Multi-point manifest that breaks if path search isn't implemented properly
SC13-demo.rdf (16.4 kB) - added by yxin 5 years ago.
SC13-demo-manifest.rdf (238.9 kB) - added by yxin 5 years ago.
manifest for the request SC13-demo.rdf
stitch-1597.rdf (243.9 kB) - added by ibaldin 5 years ago.
Cong's stitchport slices that shows disconnected nodes.

Change History

Changed 5 years ago by yxin

Changed 5 years ago by yxin

follow-up: ↓ 2   Changed 5 years ago by ibaldin

The problem is with manifest referring to real interface numbers, rather than virtual, which makes displaying paths difficult.

in reply to: ↑ 1   Changed 5 years ago by ibaldin

Replying to ibaldin:

The problem is with manifest referring to real interface numbers, rather than virtual, which makes displaying paths difficult.

Real interface URLs. To properly fix we need (just like the case of stitch ports in #299 ) to introduce virtual ports into the manifest.

Changed 5 years ago by ibaldin

Multi-point manifest that breaks if path search isn't implemented properly

follow-up: ↓ 4   Changed 5 years ago by ibaldin

  • status changed from new to closed
  • resolution set to fixed

I'm pushing a new version of Flukes (limited by the speed of my home Internet connection). It *visually* addresses this ticket for both pp and mp cases, HOWEVER, the manifest as displayed cannot be fully trusted - because the path as given in the manifest includes real interface names, which are reused across connections, I cannot verifiably compute the path as was provisioned by ORCA.

If there are say two racks in a slice that are connected via ION to DD/NLR, the paths from them to NLR via ION may lie through two ION vlans that share common interfaces - I have no way of telling which one is which without further verifying labels as assigned, which I also cannot do, since manifest doesn't include information about labels provisioned on specific interfaces.

It will have to stay this way until we change the manifest model to use virtual interfaces.

in reply to: ↑ 3   Changed 5 years ago by ibaldin

Replying to ibaldin:

r6169

Changed 5 years ago by yxin

Changed 5 years ago by yxin

manifest for the request SC13-demo.rdf

  Changed 5 years ago by yxin

  • status changed from closed to reopened
  • resolution fixed deleted

Duplicated links appeared in SC13-demo-manifest.rdf, which has mixed broadcast, p2p, node, node group,and stitching port components over ion, nor, and BEN.

Changed 5 years ago by ibaldin

Cong's stitchport slices that shows disconnected nodes.

  Changed 5 years ago by ibaldin

Cong reported a slice for GEC that shows disconnected nodes with a stitchport.

  Changed 5 years ago by ibaldin

  • summary changed from Showing extra links in manifest for Inter-domain mesh topology. to Manifest visualization issues for multipoint and stitchports

  Changed 5 years ago by ibaldin

  • status changed from reopened to closed
  • resolution set to fixed

Changes to the model in ORCA5 fix this.

Note: See TracTickets for help on using tickets.