Ticket #350 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Hybrid mode configuration and testing

Reported by: ibaldin Owned by: ibaldin
Priority: major Milestone:
Component: Don't Know Version: baseline
Keywords: Cc: yxin, jonmills, ckh, vjo, anirban, pruth

Description (last modified by ibaldin) (diff)

This ticket is specifically to track hybrid mode configuration and testing with ORCA 5.

Current status: hybrid handler has been completed (providers/quantum-vlan/handler.xml) and tested. Changes to configuration of the handler are reflected in ORCA 5.0 release notes. The handler is designed to support both pure-openflow and hybrid switches and uses the following simple logic:

IF the user specifies OF controller URL in the request - provision an Flowvisor slice and attach controller to it; configure Quantum on specified network (hopefully data-of).

IF the user DOES NOT specify OF controller, but the switch is tagged (in quantum-vlan.properties file) as OF-only/non-hybrid, create a slice in Flowvisor, create controller, attach controller to slice; configure Quantum on specified network (hopefully data-ethernet).

IF the user DOES NOT specify OF controller and the switch is tagged as hybrid, use NETCONF to configure the VLAN settings; configure Quantum on specified network (hopefully data-ethernet).

Things that still need to be resolved:

1. Does the controller send the right parameters to the handler? Of main concern here is the name of the quantum network to use for OpenFlow? dataplane, vs. the Ethernet VLAN dataplane. I believe currently the controller distinguishes between storage and data, but now there are 3 different dataplanes (storage, data-of and data-ethernet). Not clear that this is done in the controller right now.

2. What changes should be done on the configuration of the dataplane switch besides enabling hybrid mode? The architecture presumes the topology in which the OF instance is uplinked to the ethernet part of the switch, which is then uplinked to L2 provider. At the very least this seems to require reconfiguring whether the uplink port is inside OF instance or not (it is currently)

3. What changes should be done to the RDF files of the rack to support hybrid?

4. I don't know what happens when there is only one (instead of two) uplinks from worker node to an OF-only switch. Does it mean quantum networks data-of and data-ethernet are the same? Or only one exists?

5. I don't know what happens when the switch doesn't support OF at all - does the controller block attempts to setup OF VLANs?

Change History

Changed 5 years ago by ibaldin

  • description modified (diff)

Changed 5 years ago by ibaldin

Just a note that the network names in use in RDF and in Quantum are vlan-data, of-data and vlan-storage. RDF has been updated. Quantum may need to be updated. The switch should be properly configured. The likely problems with storage relate to mismatched worker node interfaces.

Changed 5 years ago by ibaldin

Hybrid testing summary - the very basic thing works (!) - creating a dumbbell or a multipoint link with all nodes connected to it and a controller given by the user.

To have more sophisticated things running we need a more robust implementation. The issue is that flowvisor refuses to create multiple slices with the same controller, and we only allow to specify one controller on the reservation, so a slice can have at most one link (broadcast or point-to-point). To resolve it we either need to make the handling of flowvisor slices smarter, however this is problematic because we have an assumption of one-slice/one link (in flowvisor) that may be difficult to overcome. The other option is to specify a controller *per-link* rather than per reservation - this requires a modification to the request format. This is 5.1 and beyond.

Changed 5 years ago by ibaldin

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.