Ticket #362 (assigned defect)

Opened 5 years ago

Last modified 5 years ago

Attaching VMs to mesoscale OF VLANs

Reported by: ibaldin Owned by: ibaldin
Priority: major Milestone:
Component: ORCA: controllers - ORCA API Version: baseline
Keywords: Cc: yxin, ckh

Description

When attaching a VM to a static vlan 1750 at RCI I get this error

Cannot create the network reservation, likely no available resource, the user specified label or hybrid OF is not valid in this site: http://geni-orca.renci.org/owl/rcivmsite.rdf#rcivmsite/Domain

This is regardless of whether OpenFlow? attributes are specified on the reservation or not.

Attached is the request file RDF and the screenshot of the error.

Attachments

Screen Shot 2014-09-16 at 4.47.42 PM.png (32.5 kB) - added by ibaldin 5 years ago.
Error screenshot
static.rdf (6.3 kB) - added by ibaldin 5 years ago.

Change History

Changed 5 years ago by ibaldin

Error screenshot

Changed 5 years ago by ibaldin

Seems to be working. Awaiting confirmation from the GPO.

Changed 5 years ago by ibaldin

  • cc yxin, ckh added
  • owner changed from yxin to ibaldin
  • status changed from new to assigned

Latest from GPO/tupty:

One small new finding... when I run the following from the VM:

arping -b 10.50.1.102 -I eth1

I can see the traffic from the VM showing up on the control plane. That
should be generating constant arp requests to the L2 bcast dst MAC. In
my previous tests, the MAC address of the hosts I was trying to ping for
had already been learned, so I didn't catch this.

It is also of note that the arp replies from BBN do get generated, and
they make it back to I2, but I never see them on the control plane from
the RENCI switch.

In summary, L2 broadcast traffic can get out into the OF portion of the
RENCI switch, but nothing else seems to. I have no good explanation for
this. Did you all do testing of the OF portion of the switch after the
firmware upgrade outside of what we are doing right now? Are you sure
it is working correctly?

Its really tough for me to say what is going on given the level of
visibility I have.

Changed 5 years ago by ibaldin

Changed 5 years ago by ibaldin

May require creating an uplink between two switch halves via the management switch as direct port linking doesn't seem to work and not recommended by IBM.

Changed 5 years ago by ibaldin

  • summary changed from Attaching VMs to static VLANs to Attaching VMs to mesoscale OF VLANs
Note: See TracTickets for help on using tickets.