Ticket #364 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

VM core accounting

Reported by: pruth Owned by: yxin
Priority: major Milestone:
Component: ORCA: Policies and their components Version: baseline
Keywords: Cc:

Description

Different size instances are not be accounted for by ORCA. All instance types (xo.small through xo.xlarge) are being charged for 1 core.

This occurs on the current production racks as well as ORCA 5 racks and the current emulation environment.

The result is that ORCA will assign far more VMs to each rack than they can handle. Once the rack is full OpenStack? will fail to create VMs. I think this might be causing the issues we saw on TAMU, FIU, and WSU.

This is a very big problem because users are seeing failures.

Change History

Changed 5 years ago by ibaldin

  • component changed from Don't Know to ORCA: Policies and their components

Changed 5 years ago by yxin

Not showing this when tested in orca50 (RCI). Maybe just a problem in orca40 when split-delegated to more than one brokers.
keep it open until more tests in other redeployed racks

Changed 5 years ago by ibaldin

Core accounting appears to work as designed, although it is less than ideal, because the controller is unable to reject certain types of requests outright, and SM satisfied partial successes, so the user may find out that something failed only as part of manifest query.

Changed 5 years ago by ibaldin

This appears resolved

Changed 5 years ago by ibaldin

  • status changed from new to closed
  • resolution set to fixed
Note: See TracTickets for help on using tickets.