Version 9 (modified by ibaldin, 10 years ago)

--

ORCA and VLANs

NOTE: THIS ASSUMES THAT LIBVIRTD IS DISABLED in DOM0

Creation of slices in ORCA consisting of edge VMs connected by VLANs should consist of the following steps

  1. Pick new VLAN tag IDs (say it is 505)
  2. Select nodes on which VMs will reside
  3. Access routers/switches on the path and configure the path for the VLAN. Assume links between network equipment and nodes are trunked.
    Vlan Declaration:
    -----------------------
    6509-Renci#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    6509-Renci(config)#vlan 505
    6509-Renci(config-vlan)#name vm2vm1
    6509-Renci(config-vlan)#exit
    6509-Renci(config)#exit
    6509-Renci#
    
    Vlan Definition:
    ---------------------
    6509-Renci#config t
    Enter configuration commands, one per line.  End with CNTL/Z.
    6509-Renci(config)#interface vlan 505
    6509-Renci(config-if)#logging event link-status
    6509-Renci(config-if)#no shut
    6509-Renci(config-if)#exit
    
    Vlan Assignment (to an interface):
    ----------------------------------------------
    6509-Renci(config-if)#interface gig1/2
    6509-Renci(config-if)#switchport
    6509-Renci(config-if)#switch
    6509-Renci(config-if)#switchport trunk encapsulation dot1q
    6509-Renci(config-if)#switchport trunk allowed vlan 505
    6509-Renci(config-if)#switchport mode trunk
    6509-Renci(config-if)#no ip address
    6509-Renci(config-if)#logging event link-status
    6509-Renci(config-if)#exit
    6509-Renci(config)#int gig1/3
    6509-Renci(config-if)#switchport
    6509-Renci(config-if)#switchport trunk encapsulation dot1q
    6509-Renci(config-if)#switchport trunk allowed vlan 505
    6509-Renci(config-if)#switchport mode trunk
    6509-Renci(config-if)#no ip address
    6509-Renci(config-if)#logging event link
    6509-Renci(config-if)#logging event link-status
    6509-Renci(config-if)#exit
    6509-Renci(config)#
    6509-Renci(config)#exit
    
  4. Create bridges in each node for this slice
    > brctl addbr bridge-for-slice1
    
  5. Create tagged interfaces in each node for the VLAN in this slice
    > vconfig add eth0 505
    > ifconfig eth0.505 up
    
  6. Attach VLAN interface to the bridge
    > brctl addif bridge-for-slice1 eth0.505
    
  7. Enable slice bridge
    > ifconfig bridge-for-slice1 up
    
  8. Create appropriate configurations for VMs
    • Data interface should have 'bridge=bridge-for-slice1' option set, to make sure that vif#.# for the data interface in the VM gets attached to the bridge
  9. Create VMs
  10. Assign IP addresses to the data interfaces in the VM
  11. Test