Changes between Version 20 and Version 21 of OrcaDevEnvironment

Show
Ignore:
Timestamp:
08/17/11 10:55:54 (8 years ago)
Author:
chase (IP: 71.65.212.97)
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • OrcaDevEnvironment

    v20 v21  
    882. In addition to the standard Eclipse installation you will need the following Eclipse plug-ins: 
    99 
    10  - Subclipse (http://subclipse.tigris.org/). This plug-in integrates subversion source control into eclipse. Make sure you choose a version compatible with your subversion command line client. Version 1.4.* uses subversion 1.5.* file formats and is incompatible with subversion 1.4.* file formats. Version 1.0.* work only with subversion 1.4.*. Be careful, which version you end up installing, since version incompatibility can cause a lot of headaches later.  Note: in a July 2010 install for a mac I used subclipse 1.6.x (http://subclipse.tigris.org/update_1.6.x/).  For this 64-bit Eclipse it was necessary to install the subversion from http://www.collab.net, as recommended by tigris.org.   (It made me register to download, but it just worked.)  Further note: in August 2011 install for OSX Lion it is STILL necessary to jump through hoops because Apple does not yet include 64-bit binaries for the JavaHL library used by subclipse.  The old fix of installing subversion from collab.net no longer works, since they don't provide packages for Lion yet.  There are various workarounds proposed on message lists, but they don't work for me.  As of now Subclipse is BROKEN ON LION.  This may change: check on collab.net for a Lion dmg. 
     10 - Subclipse (http://subclipse.tigris.org/). This plug-in integrates subversion source control into eclipse. Make sure you choose a version compatible with your subversion command line client. Version 1.4.* uses subversion 1.5.* file formats and is incompatible with subversion 1.4.* file formats. Version 1.0.* work only with subversion 1.4.*. Be careful, which version you end up installing, since version incompatibility can cause a lot of headaches later.  Note: in a July 2010 install for a mac I used subclipse 1.6.x (http://subclipse.tigris.org/update_1.6.x/).  For this 64-bit Eclipse it was necessary to install the subversion from http://www.collab.net, as recommended by tigris.org.   (It made me register to download, but it just worked.)  Further note: in August 2011 install for OSX Lion, version mismatch is no longer a problem but it is STILL necessary to jump through hoops because Apple does not yet include 64-bit binaries for the JavaHL library used by subclipse.  The old fix of installing subversion from collab.net no longer works, since they don't provide packages for Lion yet.  There are various workarounds proposed on message lists, but they don't work for me.  As of now Subclipse is BROKEN ON LION.  This may change: check on collab.net for a Lion dmg. 
    1111 
    1212 - m2eclipse (http://m2eclipse.codehaus.org/). This plug-in integrates Maven into Eclipse. The update link is http://m2eclipse.sonatype.org/sites/m2e